Stub zone easy explained

The difference between stub zone and secondary DNS zones…  It all relates to replication, efficiency and availability.

Think of it like this:
There are two cities, London and Manchester.
London has 100 people, each with a book full of information (so 100 books in total).
You are in Manchester and you want to be able to have access to the information in these “books”.

There are two ways to do this as follows:
a) Another 100 people appear in London, they each make a copy of a book, and they each take their own car in order to drive to Manchester to meet you and give you the books. This causes a traffic jam due to the high number of people driving on the highway.

The above is secondary zone replication.

b) Instead of the above, you received the address of the 100 people in London. You need information in one of the books. You decide to take your car, and you drive to the address. You found the information you need, and you drive back to Manchester.

This example is a stub zone.

So think about it for a second.
In example A, the information is stored twice, both in London and Manchester, but the information requires a big highway to transport those 100 people, each in their individual cars, to your office in Manchester. Do you have a big enough highway to support this many people?
In example B, you don’t need such a big highway because a massive number of people are not clogging the highway, each trying to bring a book to you, but instead you decide to go back to London to find the book you need.

So what do we gather from this?
In example A, you need a large highway (lots of bandwidth) to get the books from London to Manchester. But once the information is in Manchester, you can very quickly find the book you need.
In example B, you don’t need a large highway to find the book in London, but you do need a RELIABLE highway. If this highway is closed, how do you get the book? And remember, since the books are not in Manchester, it will take longer for you to get the book (since you need to drive back and forth for it).

Hope this helps, first thing that came to my mind.

Thanks to Shinigami

Cisco router change access list (ACL)

  • First check accesslist with show run
  • Then check the dialer

!
interface Dialer1
description Internet
ip address negotiated
 ip access-group 111 in
ip nat outside
ip inspect list1 out
ip virtual-reassembly

  • Copy the access group line (bold) to notepad
  • Now do a show run and copy the specific (111 in my case)  accesslist to notepad

access-list 111 permit tcp any any established
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit tcp any any eq ftp
access-list 111 permit tcp any any eq www
access-list 111 deny   ip any any log

  • Now change the ACL with the new line (bold) still in notepad

access-list 111 permit tcp any any established
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit tcp any any eq ftp
access-list 111 permit tcp any any eq www
access-list 111 permit tcp any any eq 443
access-list 111 deny   ip any any log

  • now type conf t
  • and type interface dialer1
  • now temporary disable the accesslist with: no ip access-group 111 in
  • type exit to exit the Dialer1 interface
  • type no access-list 111 to clear the current ACL
  • Past the new modified ACL fro notepad to your router
  • Type interface dialer1
  • Type ip access-group 111 in to enable new new access lists
  • Type exit
  • Test the new rule
  • Type wr mem to write the config from RAM to ROM

The Pirate Bay Mirrors

[banner]
XS4ALL and Ziggo block my favorite torrent site 🙁

Try This (dutch): http://www.ikwilthepiratebay.nl

-or-

http://malaysiabay.org/

-or-

This http://www.alwaysapirate.org/index.php and type http://thepiratebay.se/

-or-

This: http://thepiratebay.se.proxy.piratenpartij.nl/ < temp down… 🙁

-or-

Here you can find some a alterative proxies:

http://hidemyass.com/?http://www.thepiratebay.org

And click on the yellow url

And then on the yellow hide my ass button:

http://depiratebay.nl/
http://tpb.makinit.nl/
http://thepiratebay2.nl/
http://www.anti-brein.nl/piratebay/
http://tpb.dehomies.nl/
http://anonymouse.org/cgi-bin/anon-www.cgi/http://thepiratebay.se/

And do you want to run a mirror on your own wordpress blog check repress: http://wordpress.org/extend/plugins/repress/
[banner]

Configure SNMP Linux

Be careful so do a backup of the snmpd config file.

[[email protected] ~]# mv /etc/snmp/snmpd.conf /etc/snmp/snmpd.conf.org

Create a new config file.

[[email protected] ~]# nano /etc/snmp/snmpd.conf
rocommunity  public IPMonitorServer
syslocation  "Webserver, WAPNET"
syscontact  [email protected]

Start the snmpd service and set the snmp stratup at boot on

[[email protected] ~]# /etc/init.d/snmpd start
[[email protected] ~]# chkconfig snmpd on